{"action":"Upgrade whoogle-search to 0.8.4 or later.","affected":[{"fixed":"0.8.4","introduced":"0"}],"component":"whoogle-search","cve_ids":["CVE-2024-22204"],"ecosystem":"PyPI","epss":0.00757,"exploited":false,"fixed_versions":["0.8.4"],"ghsa_id":"GHSA-hh2q-qv66-jcqg","id":"tcs_01M5KGMKX7WR1H2SSHC4JQYJ0T","modified_at":"2026-06-10T17:02:51.008351664Z","published_at":"2024-01-23T18:15:00Z","references":["https://osv.dev/vulnerability/PYSEC-2024-23","https://securitylab.github.com/advisories/GHSL-2023-186_GHSL-2023-189_benbusby_whoogle-search/","https://github.com/benbusby/whoogle-search/commit/3a2e0b262e4a076a20416b45e6b6f23fd265aeda","https://github.com/benbusby/whoogle-search/blob/92e8ede24e9277a5440d403f75877209f1269884/app/routes.py#L419-L452","https://github.com/benbusby/whoogle-search/blob/92e8ede24e9277a5440d403f75877209f1269884/app/routes.py#L437","https://github.com/benbusby/whoogle-search/blob/92e8ede24e9277a5440d403f75877209f1269884/app/routes.py#L444","https://github.com/benbusby/whoogle-search/blob/92e8ede24e9277a5440d403f75877209f1269884/app/routes.py#L447","https://github.com/advisories/GHSA-hh2q-qv66-jcqg"],"severity":{"label":"medium","score":5.3},"sources":[{"source":"osv","source_id":"PYSEC-2024-23","url":"https://osv.dev/vulnerability/PYSEC-2024-23"}],"summary":"Whoogle Search is a self-hosted metasearch engine. Versions 0.8.3 and prior have a limited file write vulnerability when the configuration options in Whoogle are enabled. The `config` function in `app"}