{"action":"Upgrade apache-airflow to 2.8.2 or later.","affected":[{"fixed":"2.8.2","introduced":"0"}],"component":"apache-airflow","cve_ids":["CVE-2024-27906"],"ecosystem":"PyPI","epss":0.00345,"exploited":false,"fixed_versions":["2.8.2"],"ghsa_id":"GHSA-6v6w-h8m6-7mv2","id":"tcs_01M5KGMPV2658CVDG1HDN1DWZ2","modified_at":"2026-06-10T17:00:26.437829487Z","published_at":"2024-02-29T11:15:08Z","references":["https://osv.dev/vulnerability/PYSEC-2024-245","https://lists.apache.org/thread/on4f7t5sqr3vfgp1pvkck79wv7mq9st5","http://www.openwall.com/lists/oss-security/2024/02/29/1","https://github.com/apache/airflow/pull/37468","https://github.com/apache/airflow/pull/37290","https://github.com/advisories/GHSA-6v6w-h8m6-7mv2"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"PYSEC-2024-245","url":"https://osv.dev/vulnerability/PYSEC-2024-245"}],"summary":"Apache Airflow, versions before 2.8.2, has a vulnerability that allows authenticated users to view DAG code and import errors of DAGs they do not have permission to view through the API and the UI."}