{"action":"Upgrade vyper to 0.4.0b1 or later.","affected":[{"fixed":"0.4.0b1","introduced":"0.3.8"}],"component":"vyper","cve_ids":["CVE-2024-32481"],"ecosystem":"PyPI","epss":0.00798,"exploited":false,"fixed_versions":["0.4.0b1"],"ghsa_id":"GHSA-ppx5-q359-pvwj","id":"tcs_01M5KGMQ0P4ZBPBY51TZTHBCBH","modified_at":"2026-06-10T17:14:16.630944247Z","published_at":"2024-04-25T17:15:50Z","references":["https://osv.dev/vulnerability/PYSEC-2024-246","https://github.com/vyperlang/vyper/security/advisories/GHSA-ppx5-q359-pvwj","https://github.com/vyperlang/vyper/commit/3de1415ee77a9244eb04bdb695e249d3ec9ed868","https://github.com/vyperlang/vyper/commit/5319cfbe14951e007ccdb323257e5ada869b35d5","https://github.com/vyperlang/vyper/blob/9136169468f317a53b4e7448389aa315f90b95ba/vyper/codegen/stmt.py#L286-L287","https://github.com/advisories/GHSA-ppx5-q359-pvwj"],"severity":{"label":"medium","score":5.3},"sources":[{"source":"osv","source_id":"PYSEC-2024-246","url":"https://osv.dev/vulnerability/PYSEC-2024-246"}],"summary":"Vyper is a pythonic Smart Contract Language for the Ethereum virtual machine. Starting in version 0.3.8 and prior to version 0.4.0b1, when looping over a `range` of the form `range(start, start + N)`,"}