{"action":"Upgrade llama-index to 0.10.13 or later.","affected":[{"fixed":"0.10.13","introduced":"0.9.47"}],"component":"llama-index","cve_ids":["CVE-2024-4181"],"ecosystem":"PyPI","epss":0.02135,"exploited":false,"fixed_versions":["0.10.13"],"ghsa_id":"GHSA-pw38-xv9x-h8ch","id":"tcs_01M5KGN592HEE5DXFR3Z893N04","modified_at":"2026-07-13T07:26:21.243502373Z","published_at":"2024-05-16T09:15:15.553Z","references":["https://osv.dev/vulnerability/PYSEC-2024-324","https://github.com/run-llama/llama_index/commit/d73715eaf0642705583e7897c78b9c8dd2d3a7ba","https://huntr.com/bounties/1a204520-598a-434e-b13d-0d34f2a5ddc1"],"severity":{"label":"high","score":8.8},"sources":[{"source":"osv","source_id":"PYSEC-2024-324","url":"https://osv.dev/vulnerability/PYSEC-2024-324"}],"summary":"A command injection vulnerability exists in the RunGptLLM class of the llama_index library, version 0.9.47, used by the RunGpt framework from JinaAI to connect to Language Learning Models (LLMs). The"}