{"action":"Upgrade torch-npu to 2.2.0 or later.","affected":[{"fixed":"2.2.0","introduced":"0"}],"component":"torch-npu","cve_ids":["CVE-2024-31580"],"ecosystem":"PyPI","epss":0.00225,"exploited":false,"fixed_versions":["2.2.0"],"ghsa_id":"GHSA-5pcm-hx3q-hm94","id":"tcs_01M5KGN5WYPFSQ06E660NMJ28H","modified_at":"2026-07-27T12:26:34.306757669Z","published_at":"2024-04-17T19:15:07.783Z","references":["https://osv.dev/vulnerability/PYSEC-2024-328","https://gist.github.com/1047524396/038c78f2f007345e6f497698ace2aa3d","https://github.com/pytorch/pytorch/commit/b5c3a17c2c207ebefcb85043f0cf94be9b2fef81"],"severity":{"label":"medium","score":4},"sources":[{"source":"osv","source_id":"PYSEC-2024-328","url":"https://osv.dev/vulnerability/PYSEC-2024-328"}],"summary":"PyTorch before v2.2.0 was discovered to contain a heap buffer overflow vulnerability in the component /runtime/vararg_functions.cpp. This vulnerability allows attackers to cause a Denial of Service (D"}