{"action":"Upgrade dash to 2.13.0 or later.","affected":[{"fixed":"2.13.0","introduced":"0"},{"fixed":"2.15.0","introduced":"2.14.0"}],"component":"dash","cve_ids":["CVE-2024-21485"],"ecosystem":"PyPI","epss":0.01487,"exploited":false,"fixed_versions":["2.13.0","2.15.0"],"ghsa_id":"GHSA-547x-748v-vp6p","id":"tcs_01M5KGN6BTWW0D87SEEJ37FE6D","modified_at":"2026-06-23T10:41:07.893902418Z","published_at":"2024-02-02T05:15:00Z","references":["https://osv.dev/vulnerability/PYSEC-2024-35","https://security.snyk.io/vuln/SNYK-JS-DASHCORECOMPONENTS-6183084","https://security.snyk.io/vuln/SNYK-PYTHON-DASHCORECOMPONENTS-6226334","https://security.snyk.io/vuln/SNYK-PYTHON-DASH-6226335","https://security.snyk.io/vuln/SNYK-PYTHON-DASHHTMLCOMPONENTS-6226336","https://security.snyk.io/vuln/SNYK-JS-DASHHTMLCOMPONENTS-6226337","https://github.com/plotly/dash/issues/2729","https://github.com/plotly/dash/pull/2732","https://github.com/plotly/dash/releases/tag/v2.15.0","https://github.com/plotly/dash/commit/9920073c9a8619ae8f90fcec1924f2f3a4332a8c","https://github.com/advisories/GHSA-547x-748v-vp6p"],"severity":{"label":"medium","score":5.4},"sources":[{"source":"osv","source_id":"PYSEC-2024-35","url":"https://osv.dev/vulnerability/PYSEC-2024-35"}],"summary":"Versions of the package dash-core-components before 2.13.0; all versions of the package dash-core-components; versions of the package dash before 2.15.0; all versions of the package dash-html-componen"}