{"action":"Upgrade django to 4.2.14 or later.","affected":[{"fixed":"4.2.14","introduced":"4.2"},{"fixed":"5.0.7","introduced":"5.0"}],"component":"django","cve_ids":["CVE-2024-39614"],"ecosystem":"PyPI","epss":0.28637,"exploited":false,"fixed_versions":["5.0.7","4.2.14"],"ghsa_id":"GHSA-f6f8-9mx6-9mx2","id":"tcs_01M5KGNAV55024518KNBJWCQR9","modified_at":"2026-06-10T17:01:05.284389569Z","published_at":"2024-07-10T05:15:00Z","references":["https://osv.dev/vulnerability/PYSEC-2024-59","https://docs.djangoproject.com/en/dev/releases/security/","https://groups.google.com/forum/#%21forum/django-announce","https://www.djangoproject.com/weblog/2024/jul/09/security-releases/","https://github.com/advisories/GHSA-f6f8-9mx6-9mx2"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"PYSEC-2024-59","url":"https://osv.dev/vulnerability/PYSEC-2024-59"}],"summary":"An issue was discovered in Django 5.0 before 5.0.7 and 4.2 before 4.2.14. get_supported_language_variant() was subject to a potential denial-of-service attack when used with very long strings containi"}