{"action":"Upgrade roundup to 2.4.0 or later.","affected":[{"fixed":"2.4.0","introduced":"0"}],"component":"roundup","cve_ids":["CVE-2024-39124"],"ecosystem":"PyPI","epss":0.00291,"exploited":false,"fixed_versions":["2.4.0"],"ghsa_id":"GHSA-w8vc-cwv9-wx67","id":"tcs_01M5KGNBJR38HCFT9FAS1NTV3X","modified_at":"2026-06-10T17:02:36.720533373Z","published_at":"2024-07-17T20:15:00Z","references":["https://osv.dev/vulnerability/PYSEC-2024-63","https://www.roundup-tracker.org/","https://www.roundup-tracker.org/docs/security.html#cve-announcements","https://github.com/advisories/GHSA-w8vc-cwv9-wx67"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"PYSEC-2024-63","url":"https://osv.dev/vulnerability/PYSEC-2024-63"}],"summary":"In Roundup before 2.4.0, classhelpers (_generic.help.html) allow XSS."}