{"action":"Upgrade mindsdb to 24.7.4.1 or later.","affected":[{"fixed":"24.7.4.1","introduced":"23.12.4.0"}],"component":"mindsdb","cve_ids":["CVE-2024-45848"],"ecosystem":"PyPI","epss":0.00851,"exploited":false,"fixed_versions":["24.7.4.1"],"ghsa_id":"GHSA-9gq6-6936-885w","id":"tcs_01M5KGNEJ3TZ6Q4FCGWM6SGT59","modified_at":"2026-06-10T17:02:12.375687885Z","published_at":"2024-09-12T13:15:00Z","references":["https://osv.dev/vulnerability/PYSEC-2024-78","https://hiddenlayer.com/sai-security-advisory/2024-09-mindsdb/","https://github.com/advisories/GHSA-9gq6-6936-885w"],"severity":{"label":"high","score":8.8},"sources":[{"source":"osv","source_id":"PYSEC-2024-78","url":"https://osv.dev/vulnerability/PYSEC-2024-78"}],"summary":"An arbitrary code execution vulnerability exists in versions 23.12.4.0 up to 24.7.4.1 of the MindsDB platform, when the ChromaDB integration is installed on the server. If a specially crafted ‘INSERT’"}