{"action":"Upgrade metagpt to 0.6.5 or later.","affected":[{"fixed":"0.6.5","introduced":"0"}],"component":"metagpt","cve_ids":["CVE-2024-23750"],"ecosystem":"PyPI","epss":0.00968,"exploited":false,"fixed_versions":["0.6.5"],"ghsa_id":"GHSA-g7ph-8423-pf4j","id":"tcs_01M5KGNGPWM2N9RFFF4Y0QRFXA","modified_at":"2026-06-10T17:01:25.028247388Z","published_at":"2024-01-22T01:15:00Z","references":["https://osv.dev/vulnerability/PYSEC-2024-9","https://github.com/geekan/MetaGPT/issues/731","https://github.com/advisories/GHSA-g7ph-8423-pf4j"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"PYSEC-2024-9","url":"https://osv.dev/vulnerability/PYSEC-2024-9"}],"summary":"MetaGPT through 0.6.4 allows the QaEngineer role to execute arbitrary code because RunCode.run_script() passes shell metacharacters to subprocess.Popen."}