{"action":"Upgrade django to 4.2.18 or later.","affected":[{"fixed":"4.2.18","introduced":"4.2"},{"fixed":"5.0.11","introduced":"5.0"},{"fixed":"5.1.5","introduced":"5.1"}],"component":"django","cve_ids":["CVE-2024-56374"],"ecosystem":"PyPI","epss":0.01277,"exploited":false,"fixed_versions":["5.1.5","5.0.11","4.2.18"],"ghsa_id":"GHSA-qcgg-j2x8-h9g8","id":"tcs_01M5KGNJQWDRFCH5D66F52D2V4","modified_at":"2026-06-10T17:01:06.456982450Z","published_at":"2025-01-14T19:15:32Z","references":["https://osv.dev/vulnerability/PYSEC-2025-1","https://www.djangoproject.com/weblog/2025/jan/14/security-releases/","https://docs.djangoproject.com/en/dev/releases/security/","https://groups.google.com/g/django-announce","http://www.openwall.com/lists/oss-security/2025/01/14/2","https://github.com/advisories/GHSA-qcgg-j2x8-h9g8"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"PYSEC-2025-1","url":"https://osv.dev/vulnerability/PYSEC-2025-1"},{"source":"nvd","source_id":"CVE-2024-56374","url":"https://nvd.nist.gov/vuln/detail/CVE-2024-56374"}],"summary":"An issue was discovered in Django 5.1 before 5.1.5, 5.0 before 5.0.11, and 4.2 before 4.2.18. Lack of upper-bound limit enforcement in strings passed when performing IPv6 validation could lead to a po"}