{"action":"Upgrade onnx to 1.16.2 or later.","affected":[{"fixed":"1.16.2","introduced":"0"}],"component":"onnx","cve_ids":["CVE-2024-7776"],"ecosystem":"PyPI","epss":0.01532,"exploited":false,"fixed_versions":["1.16.2"],"ghsa_id":"GHSA-h36j-8vv3-cj52","id":"tcs_01M5KGNJWMXPA8FJSRW7BY8ZHG","modified_at":"2026-06-10T17:02:25.796712746Z","published_at":"2025-03-20T10:15:37Z","references":["https://osv.dev/vulnerability/PYSEC-2025-10","https://huntr.com/bounties/a7a46cf6-1fa0-454b-988c-62d222e83f63","https://github.com/advisories/GHSA-h36j-8vv3-cj52"],"severity":{"label":"critical","score":9.1},"sources":[{"source":"osv","source_id":"PYSEC-2025-10","url":"https://osv.dev/vulnerability/PYSEC-2025-10"}],"summary":"A vulnerability in the `download_model` function of the onnx/onnx framework, before and including version 1.16.1, allows for arbitrary file overwrite due to inadequate prevention of path traversal att"}