{"action":"Upgrade django to 4.2.25 or later.","affected":[{"fixed":"4.2.25","introduced":"4.2"},{"fixed":"5.1.13","introduced":"5.1"},{"fixed":"5.2.7","introduced":"5.2"}],"component":"django","cve_ids":["CVE-2025-59681"],"ecosystem":"PyPI","epss":0.00639,"exploited":false,"fixed_versions":["4.2.25","5.1.13","5.2.7"],"ghsa_id":"GHSA-hpr9-3m2g-3j9p","id":"tcs_01M5KGNKX452ZH692Z3BT9F8PC","modified_at":"2026-06-10T17:01:10.861599705Z","published_at":"2025-10-01T19:15:36.487Z","references":["https://osv.dev/vulnerability/PYSEC-2025-106","http://www.openwall.com/lists/oss-security/2025/10/01/3","https://docs.djangoproject.com/en/dev/releases/security/","https://groups.google.com/g/django-announce","https://www.djangoproject.com/weblog/2025/oct/01/security-releases/","https://github.com/advisories/GHSA-hpr9-3m2g-3j9p"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"PYSEC-2025-106","url":"https://osv.dev/vulnerability/PYSEC-2025-106"}],"summary":"An issue was discovered in Django 4.2 before 4.2.25, 5.1 before 5.1.13, and 5.2 before 5.2.7. QuerySet.annotate(), QuerySet.alias(), QuerySet.aggregate(), and QuerySet.extra() are subject to SQL injec"}