{"action":"Upgrade picklescan to 0.0.31 or later.","affected":[{"fixed":"0.0.31","introduced":"0"}],"component":"picklescan","cve_ids":["CVE-2025-10155"],"ecosystem":"PyPI","epss":0.00847,"exploited":false,"fixed_versions":["0.0.31"],"ghsa_id":"GHSA-jgw4-cr84-mqxg","id":"tcs_01M5KGNW74F8CXNK0JTWQBFH6W","modified_at":"2026-05-20T09:19:10.716255Z","published_at":"2025-09-17T10:15:36.913Z","references":["https://osv.dev/vulnerability/PYSEC-2025-151","https://github.com/mmaitre314/picklescan/blob/58983e1c20973ac42f2df7ff15d7c8cd32f9b688/src/picklescan/scanner.py#L463","https://github.com/mmaitre314/picklescan/security/advisories/GHSA-jgw4-cr84-mqxg"],"severity":{"label":"high","score":7.8},"sources":[{"source":"osv","source_id":"PYSEC-2025-151","url":"https://osv.dev/vulnerability/PYSEC-2025-151"}],"summary":"An Improper Input Validation vulnerability in the scanning logic of mmaitre314 picklescan versions up to and including 0.0.30 allows a remote attacker to bypass pickle files security checks by supplyi"}