{"action":"Upgrade picklescan to 0.0.21 or later.","affected":[{"fixed":"0.0.21","introduced":"0"}],"component":"picklescan","cve_ids":["CVE-2025-1716","CVE-2025-1889"],"ecosystem":"PyPI","epss":0.01723,"exploited":false,"fixed_versions":["0.0.21"],"ghsa_id":"GHSA-655q-fx9r-782v","id":"tcs_01M5KGP1668C4FDRZN3XG2E8E4","modified_at":"2025-04-09T17:59:23.478228Z","published_at":"2025-02-26T15:15:24Z","references":["https://osv.dev/vulnerability/PYSEC-2025-18","https://github.com/mmaitre314/picklescan/security/advisories/GHSA-655q-fx9r-782v","https://github.com/mmaitre314/picklescan/commit/78ce704227c51f070c0c5fb4b466d92c62a7aa3d","https://sites.google.com/sonatype.com/vulnerabilities/cve-2025-1716"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"PYSEC-2025-18","url":"https://osv.dev/vulnerability/PYSEC-2025-18"},{"source":"nvd","source_id":"CVE-2025-1716","url":"https://nvd.nist.gov/vuln/detail/CVE-2025-1716"}],"summary":"picklescan before 0.0.21 does not treat 'pip' as an unsafe global. An attacker could craft a malicious model that uses Pickle to pull in a malicious PyPI package (hosted, for example, on pypi.org or G"}