{"action":"Upgrade picklescan to 0.0.22 or later.","affected":[{"fixed":"0.0.22","introduced":"0"}],"component":"picklescan","cve_ids":["CVE-2025-1716","CVE-2025-1889"],"ecosystem":"PyPI","epss":0.01723,"exploited":false,"fixed_versions":["0.0.22"],"ghsa_id":"GHSA-655q-fx9r-782v","id":"tcs_01M5KGP37TBVF2E4C309Q2FVPZ","modified_at":"2026-07-09T16:45:06.417394050Z","published_at":"2025-03-03T19:15:34Z","references":["https://osv.dev/vulnerability/PYSEC-2025-19","https://sites.google.com/sonatype.com/vulnerabilities/cve-2025-1889","https://github.com/advisories/GHSA-769v-p64c-89pr"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"PYSEC-2025-19","url":"https://osv.dev/vulnerability/PYSEC-2025-19"}],"summary":"picklescan before 0.0.22 only considers standard pickle file extensions in the scope for its vulnerability scan. An attacker could craft a malicious model that uses Pickle and include a malicious pick"}