{"action":"Upgrade vtk to 9.5.1 or later.","affected":[{"fixed":"9.5.1","introduced":"0"}],"component":"vtk","cve_ids":["CVE-2025-57106"],"ecosystem":"PyPI","epss":0.00429,"exploited":false,"fixed_versions":["9.5.1"],"id":"tcs_01M5KGP9YK9791EC6YS3EFC3S0","modified_at":"2026-05-20T09:19:21.712041Z","published_at":"2025-10-31T15:15:42.317Z","references":["https://osv.dev/vulnerability/PYSEC-2025-224","https://gitlab.kitware.com/vtk/vtk/-/issues/19733","https://gitlab.kitware.com/vtk/vtk/-/issues/19734"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"PYSEC-2025-224","url":"https://osv.dev/vulnerability/PYSEC-2025-224"}],"summary":"Kitware VTK (Visualization Toolkit) up to 9.5.0 is vulnerable to Buffer Overflow in vtkGLTFDocumentLoader. The vulnerability occurs in the BufferDataExtractionWorker template function when processing"}