{"action":"Upgrade llama-index to 0.12.28 or later.","affected":[{"fixed":"0.12.28","introduced":"0.12.23"}],"component":"llama-index","cve_ids":["CVE-2025-3046"],"ecosystem":"PyPI","epss":0.00637,"exploited":false,"fixed_versions":["0.12.28"],"ghsa_id":"GHSA-fmrf-6jv9-qjc7","id":"tcs_01M5KGPE5RK39M6YMHFRSC7N1C","modified_at":"2026-07-13T07:26:23.351624589Z","published_at":"2025-07-07T10:15:26.900Z","references":["https://osv.dev/vulnerability/PYSEC-2025-248","https://github.com/run-llama/llama_index/commit/0008041e8dde8e519621388e5d6f558bde6ef42e","https://huntr.com/bounties/90a1f1b2-bb82-4d66-9fc1-856ed5f904da"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"PYSEC-2025-248","url":"https://osv.dev/vulnerability/PYSEC-2025-248"}],"summary":"A vulnerability in the `ObsidianReader` class of the run-llama/llama_index repository, versions 0.12.23 to 0.12.28, allows for arbitrary file read through symbolic links. The `ObsidianReader` fails to"}