{"action":"Upgrade llama-index to 0.12.38 or later.","affected":[{"fixed":"0.12.38","introduced":"0.12.28"}],"component":"llama-index","cve_ids":["CVE-2025-5472"],"ecosystem":"PyPI","epss":0.00388,"exploited":false,"fixed_versions":["0.12.38"],"ghsa_id":"GHSA-3wxx-q3gv-pvvv","id":"tcs_01M5KGPESDZMXZY7ZPVGBV29N3","modified_at":"2026-07-13T07:26:37.515124865Z","published_at":"2025-07-07T10:15:28.873Z","references":["https://osv.dev/vulnerability/PYSEC-2025-251","https://github.com/run-llama/llama_index/commit/c032843a02ce38fd8f284b2aa5a37fd1c17ae635","https://huntr.com/bounties/df187bda-7911-4823-a19a-e15b2c66b0d4"],"severity":{"label":"medium","score":6.5},"sources":[{"source":"osv","source_id":"PYSEC-2025-251","url":"https://osv.dev/vulnerability/PYSEC-2025-251"}],"summary":"The JSONReader in run-llama/llama_index versions 0.12.28 is vulnerable to a stack overflow due to uncontrolled recursive JSON parsing. This vulnerability allows attackers to trigger a Denial of Servic"}