{"action":"Upgrade llama-index to 0.5.2 or later.","affected":[{"fixed":"0.5.2","introduced":"0"}],"component":"llama-index","cve_ids":["CVE-2025-6210"],"ecosystem":"PyPI","epss":0.00334,"exploited":false,"fixed_versions":["0.5.2"],"ghsa_id":"GHSA-3j8r-jf9w-5cmh","id":"tcs_01M5KGPEYEF9J8Q347Y0YY6Y2Y","modified_at":"2026-07-13T07:26:33.207198286Z","published_at":"2025-07-07T10:15:29.040Z","references":["https://osv.dev/vulnerability/PYSEC-2025-252","https://github.com/run-llama/llama_index/commit/a86c96ae0e662492eeb471b658ae849a93f628ff","https://huntr.com/bounties/a654b322-a509-4448-a1f5-0f22850b4687"],"severity":{"label":"medium","score":6.2},"sources":[{"source":"osv","source_id":"PYSEC-2025-252","url":"https://osv.dev/vulnerability/PYSEC-2025-252"}],"summary":"A vulnerability in the ObsidianReader class of the run-llama/llama_index repository, specifically in version 0.12.27, allows for hardlink-based path traversal. This flaw permits attackers to bypass pa"}