{"action":"Upgrade max to 25.6.0 or later.","affected":[{"fixed":"25.6.0","introduced":"0"}],"component":"max","cve_ids":["CVE-2025-60455"],"ecosystem":"PyPI","epss":0.00333,"exploited":false,"fixed_versions":["25.6.0"],"ghsa_id":"GHSA-7xcv-9j6c-2fmc","id":"tcs_01M5KGPF2QQ9J4G7QPD1R80802","modified_at":"2026-07-13T07:26:46.166540840Z","published_at":"2025-11-18T19:15:49.800Z","references":["https://osv.dev/vulnerability/PYSEC-2025-253","https://github.com/modular/modular/blame/main/max/serve/kvcache_agent/kvcache_agent.py#L220","https://github.com/modular/modular/commit/10620059fb5c47fb0c30e5d21a8ff3b8d622fba4","https://github.com/modular/modular/commit/b20e749fa892dbe772e890a268002f732164d9f5","https://github.com/modular/modular/commit/ee9c4ab02345dd30bed8b79771b6909ff1b930a1","https://github.com/modular/modular/issues/4795","https://www.oligo.security/blog/shadowmq-how-code-reuse-spread-critical-vulnerabilities-across-the-ai-ecosystem"],"severity":{"label":"high","score":8.4},"sources":[{"source":"osv","source_id":"PYSEC-2025-253","url":"https://osv.dev/vulnerability/PYSEC-2025-253"}],"summary":"Unsafe Deserialization vulnerability in Modular Max Serve before 25.6, specifically when the \"--experimental-enable-kvcache-agent\" feature is used allowing attackers to execute arbitrary code."}