{"action":"Upgrade picklescan to 0.0.25 or later.","affected":[{"fixed":"0.0.25","introduced":"0"}],"component":"picklescan","cve_ids":["CVE-2025-46417"],"ecosystem":"PyPI","epss":0.00228,"exploited":false,"fixed_versions":["0.0.25"],"ghsa_id":"GHSA-93mv-x874-956g","id":"tcs_01M5KGPKNZ5JWD9BMTJJGQSC87","modified_at":"2025-04-24T03:42:20.380984Z","published_at":"2025-04-24T01:15:49Z","references":["https://osv.dev/vulnerability/PYSEC-2025-34","https://github.com/advisories/GHSA-93mv-x874-956g","https://github.com/mmaitre314/picklescan/pull/40"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"PYSEC-2025-34","url":"https://osv.dev/vulnerability/PYSEC-2025-34"},{"source":"nvd","source_id":"CVE-2025-46417","url":"https://nvd.nist.gov/vuln/detail/CVE-2025-46417"}],"summary":"The unsafe globals in Picklescan before 0.0.25 do not include ssl. Consequently, ssl.get_server_certificate can exfiltrate data via DNS after deserialization."}