{"action":"Upgrade vllm to 0.8.5 or later.","affected":[{"fixed":"0.8.5","introduced":"0.6.5"}],"component":"vllm","cve_ids":["CVE-2025-32444"],"ecosystem":"PyPI","epss":0.0182,"exploited":false,"fixed_versions":["0.8.5"],"ghsa_id":"GHSA-hj4w-hm2g-p6w5","id":"tcs_01M5KGPN3KHWBN2TA59BFXG4QK","modified_at":"2026-06-10T17:14:15.284662556Z","published_at":"2025-04-30T01:15:51Z","references":["https://osv.dev/vulnerability/PYSEC-2025-42","https://github.com/vllm-project/vllm/security/advisories/GHSA-hj4w-hm2g-p6w5","https://github.com/vllm-project/vllm/security/advisories/GHSA-x3m8-f7g5-qhm7","https://github.com/vllm-project/vllm/commit/a5450f11c95847cf51a17207af9a3ca5ab569b2c","https://github.com/vllm-project/vllm/blob/32b14baf8a1f7195ca09484de3008063569b43c5/vllm/distributed/kv_transfer/kv_pipe/mooncake_pipe.py#L179","https://github.com/advisories/GHSA-hj4w-hm2g-p6w5"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"PYSEC-2025-42","url":"https://osv.dev/vulnerability/PYSEC-2025-42"}],"summary":"vLLM is a high-throughput and memory-efficient inference and serving engine for LLMs. Versions starting from 0.6.5 and prior to 0.8.5, having vLLM integration with mooncake, are vulnerable to remote c"}