{"action":"Upgrade pypickle to 2.0.0 or later.","affected":[{"fixed":"2.0.0","introduced":"0"}],"component":"pypickle","cve_ids":["CVE-2025-5174"],"ecosystem":"PyPI","epss":0.00337,"exploited":false,"fixed_versions":["2.0.0"],"ghsa_id":"GHSA-5qwj-342r-h886","id":"tcs_01M5KGPNRAS2906R2HVJ0ZJ6Q3","modified_at":"2026-06-10T17:01:45.889019616Z","published_at":"2025-05-26T07:15:26Z","references":["https://osv.dev/vulnerability/PYSEC-2025-45","https://github.com/erdogant/pypickle/issues/2","https://github.com/erdogant/pypickle/issues/2#issuecomment-2889146579","https://vuldb.com/?ctiid.310262","https://vuldb.com/?id.310262","https://vuldb.com/?submit.579157","https://github.com/erdogant/pypickle/commit/14b4cae704a0bb4eb6723e238f25382d847a1917","https://github.com/erdogant/pypickle/releases/tag/2.0.0","https://github.com/advisories/GHSA-5qwj-342r-h886"],"severity":{"label":"high","score":7.8},"sources":[{"source":"osv","source_id":"PYSEC-2025-45","url":"https://osv.dev/vulnerability/PYSEC-2025-45"}],"summary":"A vulnerability was found in erdogant pypickle up to 1.1.5 and classified as problematic. Affected by this issue is the function load of the file pypickle/pypickle.py. The manipulation leads to deseri"}