{"action":"Upgrade pypickle to 2.0.0 or later.","affected":[{"fixed":"2.0.0","introduced":"0"}],"component":"pypickle","cve_ids":["CVE-2025-5175"],"ecosystem":"PyPI","epss":0.00247,"exploited":false,"fixed_versions":["2.0.0"],"ghsa_id":"GHSA-qpxx-2cwh-r5vh","id":"tcs_01M5KGPNWP4SN81FEWY0VEEK3J","modified_at":"2026-06-10T17:01:45.889306391Z","published_at":"2025-05-26T08:15:19Z","references":["https://osv.dev/vulnerability/PYSEC-2025-46","https://github.com/erdogant/pypickle/issues/3","https://github.com/erdogant/pypickle/issues/3#issue-3070689116","https://github.com/erdogant/pypickle/issues/3#issuecomment-2888589652","https://vuldb.com/?ctiid.310263","https://vuldb.com/?id.310263","https://vuldb.com/?submit.579824","https://github.com/erdogant/pypickle/commit/14b4cae704a0bb4eb6723e238f25382d847a1917","https://github.com/erdogant/pypickle/releases/tag/2.0.0","https://github.com/advisories/GHSA-qpxx-2cwh-r5vh"],"severity":{"label":"medium","score":5.5},"sources":[{"source":"osv","source_id":"PYSEC-2025-46","url":"https://osv.dev/vulnerability/PYSEC-2025-46"}],"summary":"A vulnerability was found in erdogant pypickle up to 1.1.5. It has been classified as critical. This affects the function Save of the file pypickle/pypickle.py. The manipulation leads to improper auth"}