{"action":"Upgrade vllm to 0.9.0 or later.","affected":[{"fixed":"0.9.0","introduced":"0.6.4"}],"component":"vllm","cve_ids":["CVE-2025-48887"],"ecosystem":"PyPI","epss":0.00541,"exploited":false,"fixed_versions":["0.9.0"],"ghsa_id":"GHSA-w6q7-j642-7c25","id":"tcs_01M5KGPPY04A7HK2GPVQJQV1J1","modified_at":"2026-06-10T17:14:19.371824623Z","published_at":"2025-05-30T18:15:32Z","references":["https://osv.dev/vulnerability/PYSEC-2025-50","https://github.com/vllm-project/vllm/security/advisories/GHSA-w6q7-j642-7c25","https://github.com/vllm-project/vllm/commit/4fc1bf813ad80172c1db31264beaef7d93fe0601","https://github.com/vllm-project/vllm/pull/18454","https://github.com/advisories/GHSA-w6q7-j642-7c25"],"severity":{"label":"medium","score":6.5},"sources":[{"source":"osv","source_id":"PYSEC-2025-50","url":"https://osv.dev/vulnerability/PYSEC-2025-50"},{"source":"nvd","source_id":"CVE-2025-48887","url":"https://nvd.nist.gov/vuln/detail/CVE-2025-48887"}],"summary":"vLLM, an inference and serving engine for large language models (LLMs), has a Regular Expression Denial of Service (ReDoS) vulnerability in the file `vllm/entrypoints/openai/tool_parsers/pythonic_tool"}