{"action":"Upgrade vllm to 0.9.0 or later.","affected":[{"fixed":"0.9.0","introduced":"0"}],"component":"vllm","cve_ids":["CVE-2025-46570"],"ecosystem":"PyPI","epss":0.0043,"exploited":false,"fixed_versions":["0.9.0"],"ghsa_id":"GHSA-4qjh-9fv9-r85r","id":"tcs_01M5KGPQG23BBJXV9Y849WMH7P","modified_at":"2025-06-26T21:44:36.898654Z","published_at":"2025-05-29T17:15:21Z","references":["https://osv.dev/vulnerability/PYSEC-2025-53","https://github.com/vllm-project/vllm/pull/17045","https://github.com/vllm-project/vllm/security/advisories/GHSA-4qjh-9fv9-r85r","https://github.com/vllm-project/vllm/commit/77073c77bc2006eb80ea6d5128f076f5e6c6f54f"],"severity":{"label":"low","score":2.6},"sources":[{"source":"osv","source_id":"PYSEC-2025-53","url":"https://osv.dev/vulnerability/PYSEC-2025-53"},{"source":"nvd","source_id":"CVE-2025-46570","url":"https://nvd.nist.gov/vuln/detail/CVE-2025-46570"}],"summary":"vLLM is an inference and serving engine for large language models (LLMs). Prior to version 0.9.0, when a new prompt is processed, if the PageAttention mechanism finds a matching prefix chunk, the pref"}