{"action":"Upgrade vllm to 0.9.0 or later.","affected":[{"fixed":"0.9.0","introduced":"0.8.0"}],"component":"vllm","cve_ids":["CVE-2025-48942"],"ecosystem":"PyPI","epss":0.00575,"exploited":false,"fixed_versions":["0.9.0"],"ghsa_id":"GHSA-6qc9-v4r8-22xg","id":"tcs_01M5KGPQZEBXX7BV0GQ0D65F09","modified_at":"2025-06-26T21:44:31.167227Z","published_at":"2025-05-30T19:15:30Z","references":["https://osv.dev/vulnerability/PYSEC-2025-54","https://github.com/vllm-project/vllm/security/advisories/GHSA-6qc9-v4r8-22xg","https://github.com/vllm-project/vllm/commit/08bf7840780980c7568c573c70a6a8db94fd45ff","https://github.com/vllm-project/vllm/pull/17623","https://github.com/vllm-project/vllm/issues/17248"],"severity":{"label":"medium","score":6.5},"sources":[{"source":"osv","source_id":"PYSEC-2025-54","url":"https://osv.dev/vulnerability/PYSEC-2025-54"},{"source":"nvd","source_id":"CVE-2025-48942","url":"https://nvd.nist.gov/vuln/detail/CVE-2025-48942"}],"summary":"vLLM is an inference and serving engine for large language models (LLMs). In versions 0.8.0 up to but excluding 0.9.0, hitting the /v1/completions API with a invalid json_schema as a Guided Param kill"}