{"action":"Upgrade vllm to 0.8.0 or later.","affected":[{"fixed":"0.8.0","introduced":"0.6.5"}],"component":"vllm","cve_ids":["CVE-2025-29783"],"ecosystem":"PyPI","epss":0.00734,"exploited":false,"fixed_versions":["0.8.0"],"ghsa_id":"GHSA-x3m8-f7g5-qhm7","id":"tcs_01M5KGPSPR5KW828FDDWG9W6SM","modified_at":"2025-07-01T23:59:56.271533Z","published_at":"2025-03-19T16:15:32Z","references":["https://osv.dev/vulnerability/PYSEC-2025-63","https://github.com/vllm-project/vllm/pull/14228","https://github.com/vllm-project/vllm/security/advisories/GHSA-x3m8-f7g5-qhm7","https://github.com/vllm-project/vllm/commit/288ca110f68d23909728627d3100e5a8db820aa2"],"severity":{"label":"critical","score":9},"sources":[{"source":"osv","source_id":"PYSEC-2025-63","url":"https://osv.dev/vulnerability/PYSEC-2025-63"},{"source":"nvd","source_id":"CVE-2025-29783","url":"https://nvd.nist.gov/vuln/detail/CVE-2025-29783"}],"summary":"vLLM is a high-throughput and memory-efficient inference and serving engine for LLMs. When vLLM is configured to use Mooncake, unsafe deserialization exposed directly over ZMQ/TCP on all network inter"}