{"action":"Upgrade langflow to 1.7.0 or later.","affected":[{"fixed":"1.7.0","introduced":"0"}],"component":"langflow","cve_ids":["CVE-2025-34291"],"ecosystem":"PyPI","epss":0.92808,"exploited":true,"fixed_versions":["1.7.0"],"ghsa_id":"GHSA-577h-p2hh-v4mv","id":"tcs_01M5KGPW5F6V9P4AW3JECJ1X2Y","modified_at":"2026-06-10T17:01:58.704525618Z","published_at":"2025-12-05T23:15:47.433Z","references":["https://osv.dev/vulnerability/PYSEC-2025-78","https://www.vulncheck.com/advisories/langflow-cors-misconfiguration-to-token-hijack-and-rce","https://github.com/langflow-ai/langflow","https://www.obsidiansecurity.com/blog/cve-2025-34291-critical-account-takeover-and-rce-vulnerability-in-the-langflow-ai-agent-workflow-platform","https://github.com/advisories/GHSA-577h-p2hh-v4mv"],"severity":{"label":"high","score":8.8},"sources":[{"source":"osv","source_id":"PYSEC-2025-78","url":"https://osv.dev/vulnerability/PYSEC-2025-78"},{"source":"kev","source_id":"CVE-2025-34291","url":"https://www.cisa.gov/sites/default/files/feeds/known_exploited_vulnerabilities.json"}],"summary":"Langflow versions up to and including 1.6.9 contain a chained vulnerability that enables account takeover and remote code execution. An overly permissive CORS configuration (allow_origins='*' with all"}