{"action":"Upgrade invokeai to 5.4.3rc1 or later.","affected":[{"fixed":"5.4.3rc1","introduced":"5.3.1"}],"component":"invokeai","cve_ids":["CVE-2024-12029"],"ecosystem":"PyPI","epss":0.05983,"exploited":false,"fixed_versions":["5.4.3rc1"],"ghsa_id":"GHSA-mcrp-whpw-jp68","id":"tcs_01M5KGPYMPGM08DG2DN1Y6JD2T","modified_at":"2026-06-10T17:01:32.316547770Z","published_at":"2025-03-20T10:15:26Z","references":["https://osv.dev/vulnerability/PYSEC-2025-9","https://github.com/invoke-ai/invokeai/commit/756008dc5899081c5aa51e5bd8f24c1b3975a59e","https://huntr.com/bounties/9b790f94-1b1b-4071-bc27-78445d1a87a3","https://github.com/advisories/GHSA-mcrp-whpw-jp68"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"PYSEC-2025-9","url":"https://osv.dev/vulnerability/PYSEC-2025-9"}],"summary":"A remote code execution vulnerability exists in invoke-ai/invokeai versions 5.3.1 through 5.4.2 via the /api/v2/models/install API. The vulnerability arises from unsafe deserialization of model files"}