{"action":"Upgrade tensorflow-gpu to 2.7.2 or later.","affected":[{"fixed":"2.7.2","introduced":"0"},{"fixed":"2.8.1","introduced":"2.8.0"},{"fixed":"2.9.1","introduced":"2.9.0"}],"component":"tensorflow-gpu","cve_ids":["CVE-2022-35940"],"ecosystem":"PyPI","epss":0.00701,"exploited":false,"fixed_versions":["2.7.2","2.8.1","2.9.1"],"ghsa_id":"GHSA-x989-q2pq-4q5x","id":"tcs_01M5KGQ9BKPTEVG1TEGM0084WN","modified_at":"2026-07-13T16:43:21.603978969Z","published_at":"2026-07-07T10:17:20.354916Z","references":["https://osv.dev/vulnerability/PYSEC-2026-1047","https://github.com/tensorflow/tensorflow/security/advisories/GHSA-x989-q2pq-4q5x","https://nvd.nist.gov/vuln/detail/CVE-2022-35940","https://github.com/tensorflow/tensorflow/commit/37cefa91bee4eace55715eeef43720b958a01192","https://github.com/tensorflow/tensorflow","https://github.com/tensorflow/tensorflow/blob/0b6b491d21d6a4eb5fbab1cca565bc1e94ca9543/tensorflow/core/kernels/ragged_range_op.cc#L74-L88","https://github.com/tensorflow/tensorflow/releases/tag/v2.10.0","https://pypi.org/project/tensorflow-gpu","https://github.com/advisories/GHSA-x989-q2pq-4q5x"],"severity":{"label":"medium","score":5.9},"sources":[{"source":"osv","source_id":"PYSEC-2026-1047","url":"https://osv.dev/vulnerability/PYSEC-2026-1047"}],"summary":"TensorFlow vulnerable to Int overflow in `RaggedRangeOp`"}