{"action":"Upgrade uwsgi to 2.0.22 or later.","affected":[{"fixed":"2.0.22","introduced":"0"}],"component":"uwsgi","cve_ids":["CVE-2023-27522"],"ecosystem":"PyPI","epss":0.02134,"exploited":false,"fixed_versions":["2.0.22"],"ghsa_id":"GHSA-vcph-37mh-fqrh","id":"tcs_01M5KGQB416QVEJZAYZFSS2ZQE","modified_at":"2026-07-07T11:56:18.462638605Z","published_at":"2026-07-07T10:17:28.280695Z","references":["https://osv.dev/vulnerability/PYSEC-2026-1058","https://nvd.nist.gov/vuln/detail/CVE-2023-27522","https://github.com/apache/httpd/commit/d753ea76b5972a85349b68c31b59d04c60014f2d","https://github.com/unbit/uwsgi/commit/58ee1df31fa9e9af106aaeabb82374c36b433822","https://github.com/unbit/uwsgi/commit/acb03530aaaeaa810f28a5b64da619525940f569","https://github.com/unbit/uwsgi","https://httpd.apache.org/security/vulnerabilities_24.html","https://lists.debian.org/debian-lts-announce/2023/04/msg00028.html","https://security.gentoo.org/glsa/202309-01","https://uwsgi-docs.readthedocs.io/en/latest/Changelog-2.0.22.html","https://pypi.org/project/uwsgi","https://github.com/advisories/GHSA-vcph-37mh-fqrh"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"PYSEC-2026-1058","url":"https://osv.dev/vulnerability/PYSEC-2026-1058"}],"summary":"Apache HTTP Server via mod_proxy_uwsgi HTTP response smuggling"}