{"action":"Upgrade werkzeug to 0.15.5 or later.","affected":[{"fixed":"0.15.5","introduced":"0"}],"component":"werkzeug","cve_ids":["CVE-2019-14322"],"ecosystem":"PyPI","epss":0.55803,"exploited":false,"fixed_versions":["0.15.5"],"ghsa_id":"GHSA-j544-7q9p-6xp8","id":"tcs_01M5KGQCJQRF2YXTW8E47SERXQ","modified_at":"2026-07-07T11:45:36.920070957Z","published_at":"2026-07-06T08:03:28.302032Z","references":["https://osv.dev/vulnerability/PYSEC-2026-1065","https://nvd.nist.gov/vuln/detail/CVE-2019-14322","https://github.com/pallets/werkzeug","https://palletsprojects.com/blog/werkzeug-0-15-5-released","http://packetstormsecurity.com/files/163398/Pallets-Werkzeug-0.15.4-Path-Traversal.html","https://pypi.org/project/werkzeug","https://github.com/advisories/GHSA-j544-7q9p-6xp8"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"PYSEC-2026-1065","url":"https://osv.dev/vulnerability/PYSEC-2026-1065"}],"summary":"Pallets Werkzeug vulnerable to Path Traversal"}