{"action":"Upgrade apache-airflow-providers-apache-drill to 2.3.2 or later.","affected":[{"fixed":"2.3.2","introduced":"0"}],"component":"apache-airflow-providers-apache-drill","cve_ids":["CVE-2023-28707"],"ecosystem":"PyPI","epss":0.02062,"exploited":false,"fixed_versions":["2.3.2"],"ghsa_id":"GHSA-85pf-r4c7-3j9r","id":"tcs_01M5KGQSGH3BSZA2D5EBS707NJ","modified_at":"2026-07-07T17:57:36.626064859Z","published_at":"2026-07-07T11:45:17.937952Z","references":["https://osv.dev/vulnerability/PYSEC-2026-1136","https://nvd.nist.gov/vuln/detail/CVE-2023-28707","https://github.com/apache/airflow/pull/30215","https://github.com/apache/airflow/commit/63d9b24aad0b4b9397682ddac1ea5824354789b3","https://github.com/apache/airflow","https://github.com/pypa/advisory-database/tree/main/vulns/apache-airflow/PYSEC-2023-3.yaml","https://lists.apache.org/thread/dfoj7q1nd0vhhsl8fjg63z4j6mfmdxtk","https://www.openwall.com/lists/oss-security/2023/04/07/1","http://www.openwall.com/lists/oss-security/2023/04/07/1","https://pypi.org/project/apache-airflow-providers-apache-drill","https://github.com/advisories/GHSA-85pf-r4c7-3j9r"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"PYSEC-2026-1136","url":"https://osv.dev/vulnerability/PYSEC-2026-1136"}],"summary":"Apache Airflow Drill Provider vulnerable to improper input validation"}