{"action":"Upgrade apache-airflow-providers-apache-drill to 2.4.3 or later.","affected":[{"fixed":"2.4.3","introduced":"0"}],"component":"apache-airflow-providers-apache-drill","cve_ids":["CVE-2023-39553"],"ecosystem":"PyPI","epss":0.02284,"exploited":false,"fixed_versions":["2.4.3"],"ghsa_id":"GHSA-mq4v-6vg4-796c","id":"tcs_01M5KGQSNCY2RTM9KVCVDJGKKT","modified_at":"2026-07-07T17:56:40.304168930Z","published_at":"2026-07-07T11:45:22.484409Z","references":["https://osv.dev/vulnerability/PYSEC-2026-1137","https://nvd.nist.gov/vuln/detail/CVE-2023-39553","https://github.com/apache/airflow/pull/33074","https://github.com/apache/airflow/commit/394a727ac2c18d58978bf186a7a92923460ec110","https://github.com/apache/airflow","https://github.com/pypa/advisory-database/tree/main/vulns/apache-airflow/PYSEC-2023-136.yaml","https://lists.apache.org/thread/ozpl0opmob49rkcz8svo8wkxyw1395sf","https://www.openwall.com/lists/oss-security/2023/08/11/1","http://www.openwall.com/lists/oss-security/2023/08/11/1","https://pypi.org/project/apache-airflow-providers-apache-drill","https://github.com/advisories/GHSA-mq4v-6vg4-796c"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"PYSEC-2026-1137","url":"https://osv.dev/vulnerability/PYSEC-2026-1137"}],"summary":"apache-airflow-providers-apache-drill Improper Input Validation vulnerability"}