{"action":"Upgrade apache-airflow-providers-apache-spark to 4.1.3 or later.","affected":[{"fixed":"4.1.3","introduced":"0"}],"component":"apache-airflow-providers-apache-spark","cve_ids":["CVE-2023-40272"],"ecosystem":"PyPI","epss":0.02144,"exploited":false,"fixed_versions":["4.1.3"],"ghsa_id":"GHSA-r2f6-6928-fh8f","id":"tcs_01M5KGQTEPTE6V4G8ZRQK74CQJ","modified_at":"2026-07-07T17:46:22.285578508Z","published_at":"2026-07-07T11:45:22.757343Z","references":["https://osv.dev/vulnerability/PYSEC-2026-1141","https://nvd.nist.gov/vuln/detail/CVE-2023-40272","https://lists.apache.org/thread/t03gktyzyor20rh06okd91jtqmw6k1l7","http://www.openwall.com/lists/oss-security/2023/08/17/1","http://www.openwall.com/lists/oss-security/2023/08/18/1","https://pypi.org/project/apache-airflow-providers-apache-spark","https://github.com/advisories/GHSA-r2f6-6928-fh8f"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"PYSEC-2026-1141","url":"https://osv.dev/vulnerability/PYSEC-2026-1141"}],"summary":"Apache Airflow Spark Provider Improper Input Validation vulnerability"}