{"action":"Upgrade apache-airflow-providers-apache-sqoop to 4.0.0 or later.","affected":[{"fixed":"4.0.0","introduced":"0"}],"component":"apache-airflow-providers-apache-sqoop","cve_ids":["CVE-2023-27604"],"ecosystem":"PyPI","epss":0.01655,"exploited":false,"fixed_versions":["4.0.0"],"ghsa_id":"GHSA-g3m9-pr5m-4cvp","id":"tcs_01M5KGQTK2SKEM4W6HVZ9HG7EB","modified_at":"2026-07-07T17:46:22.273772526Z","published_at":"2026-07-07T11:45:23.063646Z","references":["https://osv.dev/vulnerability/PYSEC-2026-1142","https://nvd.nist.gov/vuln/detail/CVE-2023-27604","https://github.com/apache/airflow/pull/33039","https://github.com/apache/airflow","https://lists.apache.org/thread/lswlxf11do51ob7f6xyyg8qp3n7wdrgd","https://pypi.org/project/apache-airflow-providers-apache-sqoop","https://github.com/advisories/GHSA-g3m9-pr5m-4cvp"],"severity":{"label":"high","score":8.8},"sources":[{"source":"osv","source_id":"PYSEC-2026-1142","url":"https://osv.dev/vulnerability/PYSEC-2026-1142"}],"summary":"Airflow Sqoop Provider RCE Vulnerability"}