{"action":"Upgrade apache-superset to 3.0.4 or later.","affected":[{"fixed":"3.0.4","introduced":"0"},{"fixed":"3.1.1","introduced":"3.1.0"}],"component":"apache-superset","cve_ids":["CVE-2024-24773"],"ecosystem":"PyPI","epss":0.00779,"exploited":false,"fixed_versions":["3.0.4","3.1.1"],"ghsa_id":"GHSA-5474-f7g5-273q","id":"tcs_01M5KGQXZPFZ1TP0WJ5SKC1KKN","modified_at":"2026-07-07T17:57:11.992856010Z","published_at":"2026-07-07T11:45:33.225746Z","references":["https://osv.dev/vulnerability/PYSEC-2026-1160","https://nvd.nist.gov/vuln/detail/CVE-2024-24773","https://github.com/apache/superset","https://lists.apache.org/thread/h66fy6nj41cfx07zh7l552w6dmtjh501","http://www.openwall.com/lists/oss-security/2024/02/28/4","https://pypi.org/project/apache-superset","https://github.com/advisories/GHSA-5474-f7g5-273q"],"severity":{"label":"medium","score":4.9},"sources":[{"source":"osv","source_id":"PYSEC-2026-1160","url":"https://osv.dev/vulnerability/PYSEC-2026-1160"}],"summary":"Apache Superset: Improper validation of SQL statements allows for unauthorized access to data"}