{"action":"Upgrade apache-superset to 3.1.3 or later.","affected":[{"fixed":"3.1.3","introduced":"0"},{"fixed":"4.0.1","introduced":"4.0.0"}],"component":"apache-superset","cve_ids":["CVE-2024-34693"],"ecosystem":"PyPI","epss":0.01584,"exploited":false,"fixed_versions":["3.1.3","4.0.1"],"ghsa_id":"GHSA-hcr7-cqwc-q5gq","id":"tcs_01M5KGR23Z91SQTB0GPZ3DCVXE","modified_at":"2026-07-07T17:57:00.178717904Z","published_at":"2026-07-07T14:34:35.071544Z","references":["https://osv.dev/vulnerability/PYSEC-2026-1183","https://nvd.nist.gov/vuln/detail/CVE-2024-34693","https://github.com/apache/superset","https://lists.apache.org/thread/1803x1s34m7r71h1k0q1njol8k6fmyon","http://www.openwall.com/lists/oss-security/2024/06/20/1","https://pypi.org/project/apache-superset","https://github.com/advisories/GHSA-hcr7-cqwc-q5gq"],"severity":{"label":"medium","score":6.8},"sources":[{"source":"osv","source_id":"PYSEC-2026-1183","url":"https://osv.dev/vulnerability/PYSEC-2026-1183"}],"summary":"Apache Superset server arbitrary file read"}