{"action":"Upgrade changedetection-io to 0.48.05 or later.","affected":[{"fixed":"0.48.05","introduced":"0"}],"component":"changedetection-io","cve_ids":["CVE-2024-56509"],"ecosystem":"PyPI","epss":0.00715,"exploited":false,"fixed_versions":["0.48.05"],"ghsa_id":"GHSA-j5vv-6wjg-cfr8","id":"tcs_01M5KGRDT927R3HH1AQKBES0VP","modified_at":"2026-07-07T17:47:26.890146780Z","published_at":"2026-07-07T14:34:48.021723Z","references":["https://osv.dev/vulnerability/PYSEC-2026-1242","https://github.com/dgtlmoon/changedetection.io/security/advisories/GHSA-j5vv-6wjg-cfr8","https://nvd.nist.gov/vuln/detail/CVE-2024-56509","https://github.com/dgtlmoon/changedetection.io/commit/4419bc0e61d0b03c588bd573a3602bbcfd953671","https://github.com/dgtlmoon/changedetection.io/commit/f7e9846c9b40a229813d19cdb66bf60fbe5e6a2a","https://github.com/dgtlmoon/changedetection.io","https://pypi.org/project/changedetection-io","https://github.com/advisories/GHSA-j5vv-6wjg-cfr8"],"severity":{"label":"high","score":8.6},"sources":[{"source":"osv","source_id":"PYSEC-2026-1242","url":"https://osv.dev/vulnerability/PYSEC-2026-1242"}],"summary":"changedetection.io Vulnerable to Improper Input Validation Leading to LFR/Path Traversal"}