{"action":"Upgrade dagster to 1.5.11 or later.","affected":[{"fixed":"1.5.11","introduced":"0"}],"component":"dagster","cve_ids":["CVE-2023-51232"],"ecosystem":"PyPI","epss":0.00946,"exploited":false,"fixed_versions":["1.5.11"],"ghsa_id":"GHSA-q93c-p2mw-p23f","id":"tcs_01M5KGRP66Z82P6SVH37ED8CA9","modified_at":"2026-07-07T17:47:34.755473440Z","published_at":"2026-07-07T16:02:57.214853Z","references":["https://osv.dev/vulnerability/PYSEC-2026-1287","https://nvd.nist.gov/vuln/detail/CVE-2023-51232","https://github.com/dagster-io/dagster/pull/18462","https://github.com/dagster-io/dagster/commit/dbb064c2ddda74265b8174edd9775e1302ca6ba0","https://github.com/dagster-io/dagster","https://pypi.org/project/dagster","https://github.com/advisories/GHSA-q93c-p2mw-p23f"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"PYSEC-2026-1287","url":"https://osv.dev/vulnerability/PYSEC-2026-1287"}],"summary":"Dagster vulnerable to Path Traversal attack through its /logs endpoint"}