{"action":"Upgrade strawberry-graphql to 0.312.3 or later.","affected":[{"fixed":"0.312.3","introduced":"0"}],"component":"strawberry-graphql","cve_ids":["CVE-2026-35523"],"ecosystem":"PyPI","epss":0.00424,"exploited":false,"fixed_versions":["0.312.3"],"ghsa_id":"GHSA-vpwc-v33q-mq89","id":"tcs_01M5KGRYMX1KD6R169PTCACQ9M","modified_at":"2026-05-20T09:19:17.609380Z","published_at":"2026-04-07T17:16:31.583Z","references":["https://osv.dev/vulnerability/PYSEC-2026-133","https://github.com/strawberry-graphql/strawberry/security/advisories/GHSA-vpwc-v33q-mq89"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"PYSEC-2026-133","url":"https://osv.dev/vulnerability/PYSEC-2026-133"}],"summary":"Strawberry GraphQL is a library for creating GraphQL APIs. Strawberry up until version 0.312.3 is vulnerable to an authentication bypass on WebSocket subscription endpoints. The legacy graphql-ws subp"}