{"action":"Upgrade fastapi-sso to 0.19.0 or later.","affected":[{"fixed":"0.19.0","introduced":"0"}],"component":"fastapi-sso","cve_ids":["CVE-2025-14546"],"ecosystem":"PyPI","epss":0.00359,"exploited":false,"fixed_versions":["0.19.0"],"ghsa_id":"GHSA-hp6r-r9vc-q8wx","id":"tcs_01M5KGS4XYKQB6GZCFT1R7MVP6","modified_at":"2026-07-07T17:47:35.987584320Z","published_at":"2026-07-07T16:03:13.588483Z","references":["https://osv.dev/vulnerability/PYSEC-2026-1362","https://nvd.nist.gov/vuln/detail/CVE-2025-14546","https://github.com/tomasvotava/fastapi-sso/issues/266","https://github.com/tomasvotava/fastapi-sso/commit/6117d1a5ad498ba57d671e8a059ebe20db5abe02","https://github.com/tomasvotava/fastapi-sso","https://security.snyk.io/vuln/SNYK-PYTHON-FASTAPISSO-14386403","https://pypi.org/project/fastapi-sso","https://github.com/advisories/GHSA-hp6r-r9vc-q8wx"],"severity":{"label":"medium","score":6.3},"sources":[{"source":"osv","source_id":"PYSEC-2026-1362","url":"https://osv.dev/vulnerability/PYSEC-2026-1362"}],"summary":"FastAPI SSP is vulnerable to Cross-site Request Forgery (CSRF) through improper OAuth parameter validation"}