{"action":"Upgrade grpcio to 1.53.1 or later.","affected":[{"fixed":"1.53.1","introduced":"1.53.0"},{"fixed":"1.54.2","introduced":"1.54.0"}],"component":"grpcio","cve_ids":["CVE-2023-32731"],"ecosystem":"PyPI","epss":0.00498,"exploited":false,"fixed_versions":["1.53.1","1.54.2"],"ghsa_id":"GHSA-cfgp-2977-2fmm","id":"tcs_01M5KGSHJHNV2CG6270161E3YK","modified_at":"2026-07-07T17:47:41.821414149Z","published_at":"2026-07-07T11:45:19.959086Z","references":["https://osv.dev/vulnerability/PYSEC-2026-1427","https://nvd.nist.gov/vuln/detail/CVE-2023-32731","https://github.com/grpc/grpc/issues/33463","https://github.com/grpc/grpc/pull/32309","https://github.com/grpc/grpc/pull/33005","https://github.com/grpc/grpc/commit/29d8beee0ac2555773b2a2dda5601c74a95d6c10","https://github.com/grpc/grpc/commit/65a2a895afaf1d2072447b9baf246374b182a946","https://github.com/grpc/grpc/releases/tag/v1.53.1","https://github.com/grpc/grpc/releases/tag/v1.54.2","https://github.com/rubysec/ruby-advisory-db/blob/master/gems/grpc/CVE-2023-32731.yml","https://pypi.org/project/grpcio","https://github.com/advisories/GHSA-cfgp-2977-2fmm"],"severity":{"label":"high","score":7.4},"sources":[{"source":"osv","source_id":"PYSEC-2026-1427","url":"https://osv.dev/vulnerability/PYSEC-2026-1427"}],"summary":"Connection confusion in gRPC"}