{"action":"Upgrade grpcio to 1.53.2 or later.","affected":[{"fixed":"1.53.2","introduced":"1.53.0"},{"fixed":"1.54.3","introduced":"1.54.0"},{"fixed":"1.55.3","introduced":"1.55.0"}],"component":"grpcio","cve_ids":["CVE-2023-4785"],"ecosystem":"PyPI","epss":0.00773,"exploited":false,"fixed_versions":["1.55.3","1.54.3","1.53.2"],"ghsa_id":"GHSA-p25m-jpj4-qcrr","id":"tcs_01M5KGSHQPGZQWCWREBTSTQMXD","modified_at":"2026-07-07T17:47:41.898069367Z","published_at":"2026-07-07T11:45:24.303647Z","references":["https://osv.dev/vulnerability/PYSEC-2026-1428","https://nvd.nist.gov/vuln/detail/CVE-2023-4785","https://github.com/grpc/grpc/pull/33656","https://github.com/grpc/grpc/pull/33667","https://github.com/grpc/grpc/pull/33669","https://github.com/grpc/grpc/pull/33670","https://github.com/grpc/grpc/pull/33672","https://github.com/rubysec/ruby-advisory-db/blob/master/gems/grpc/CVE-2023-4785.yml","https://groups.google.com/g/grpc-io/c/LlLkB1CeE4U","https://rubygems.org/gems/grpc/versions/1.53.2","https://rubygems.org/gems/grpc/versions/1.54.3","https://rubygems.org/gems/grpc/versions/1.55.3","https://rubygems.org/gems/grpc/versions/1.56.2","https://pypi.org/project/grpcio","https://github.com/advisories/GHSA-p25m-jpj4-qcrr"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"PYSEC-2026-1428","url":"https://osv.dev/vulnerability/PYSEC-2026-1428"}],"summary":"Denial of Service Vulnerability in gRPC TCP Server (Posix-compatible platforms)"}