{"action":"Upgrade vllm to 0.20.0 or later.","affected":[{"fixed":"0.20.0","introduced":"0.18.0"}],"component":"vllm","cve_ids":["CVE-2026-44223"],"ecosystem":"PyPI","epss":0.00367,"exploited":false,"fixed_versions":["0.20.0"],"ghsa_id":"GHSA-83vm-p52w-f9pw","id":"tcs_01M5KGSNZ0H3C1K9AEKCKED7YN","modified_at":"2026-05-20T09:19:21.596358Z","published_at":"2026-05-12T20:16:43.293Z","references":["https://osv.dev/vulnerability/PYSEC-2026-145","https://github.com/vllm-project/vllm/security/advisories/GHSA-83vm-p52w-f9pw","https://github.com/vllm-project/vllm/pull/38610"],"severity":{"label":"medium","score":6.5},"sources":[{"source":"osv","source_id":"PYSEC-2026-145","url":"https://osv.dev/vulnerability/PYSEC-2026-145"}],"summary":"vLLM is an inference and serving engine for large language models (LLMs). From to before 0.20.0, the extract_hidden_states speculative decoding proposer in vLLM returns a tensor with an incorrect shap"}