{"action":"Upgrade llama-index-readers-obsidian to 0.5.2 or later.","affected":[{"fixed":"0.5.2","introduced":"0"}],"component":"llama-index-readers-obsidian","cve_ids":["CVE-2025-6210"],"ecosystem":"PyPI","epss":0.00334,"exploited":false,"fixed_versions":["0.5.2"],"ghsa_id":"GHSA-3j8r-jf9w-5cmh","id":"tcs_01M5KGTC884B1T63GE76MV3MAZ","modified_at":"2026-07-13T07:26:33.207198286Z","published_at":"2026-07-07T16:02:56.964090Z","references":["https://osv.dev/vulnerability/PYSEC-2026-1567","https://nvd.nist.gov/vuln/detail/CVE-2025-6210","https://github.com/run-llama/llama_index/commit/a86c96ae0e662492eeb471b658ae849a93f628ff","https://github.com/run-llama/llama_index","https://huntr.com/bounties/a654b322-a509-4448-a1f5-0f22850b4687","https://pypi.org/project/llama-index-readers-obsidian","https://github.com/advisories/GHSA-3j8r-jf9w-5cmh"],"severity":{"label":"medium","score":6.2},"sources":[{"source":"osv","source_id":"PYSEC-2026-1567","url":"https://osv.dev/vulnerability/PYSEC-2026-1567"}],"summary":"LlamaIndex vulnerability in its ObsidianReader class can lead to Path Traversal exploit"}