{"action":"Upgrade matrix-synapse to 1.127.1 or later.","affected":[{"fixed":"1.127.1","introduced":"0"}],"component":"matrix-synapse","cve_ids":["CVE-2025-30355"],"ecosystem":"PyPI","epss":0.01226,"exploited":false,"fixed_versions":["1.127.1"],"ghsa_id":"GHSA-v56r-hwv5-mxg6","id":"tcs_01M5KGTN4NHAWZJTT1C2T16T6V","modified_at":"2026-07-07T17:46:57.350680763Z","published_at":"2026-07-07T14:34:59.084265Z","references":["https://osv.dev/vulnerability/PYSEC-2026-1614","https://github.com/element-hq/synapse/security/advisories/GHSA-v56r-hwv5-mxg6","https://nvd.nist.gov/vuln/detail/CVE-2025-30355","https://github.com/element-hq/synapse/commit/2277df2a1eb685f85040ef98fa21d41aa4cdd389","https://github.com/element-hq/synapse","https://github.com/element-hq/synapse/releases/tag/v1.127.1","https://pypi.org/project/matrix-synapse","https://github.com/advisories/GHSA-v56r-hwv5-mxg6"],"severity":{"label":"high","score":7.1},"sources":[{"source":"osv","source_id":"PYSEC-2026-1614","url":"https://osv.dev/vulnerability/PYSEC-2026-1614"}],"summary":"Synapse vulnerable to federation denial of service via malformed events"}