{"action":"Upgrade nicegui to 3.5.0 or later.","affected":[{"fixed":"3.5.0","introduced":"2.22.0"}],"component":"nicegui","cve_ids":["CVE-2026-21872"],"ecosystem":"PyPI","epss":0.00271,"exploited":false,"fixed_versions":["3.5.0"],"ghsa_id":"GHSA-m7j5-rq9j-6jj9","id":"tcs_01M5KGV5WF98DPV0EZ5G71XCBT","modified_at":"2026-07-07T17:46:58.650836097Z","published_at":"2026-07-07T16:03:17.198320Z","references":["https://osv.dev/vulnerability/PYSEC-2026-1701","https://github.com/zauberzeug/nicegui/security/advisories/GHSA-m7j5-rq9j-6jj9","https://nvd.nist.gov/vuln/detail/CVE-2026-21872","https://github.com/zauberzeug/nicegui","https://github.com/zauberzeug/nicegui/releases/tag/v3.5.0","https://pypi.org/project/nicegui","https://github.com/advisories/GHSA-m7j5-rq9j-6jj9"],"severity":{"label":"medium","score":6.1},"sources":[{"source":"osv","source_id":"PYSEC-2026-1701","url":"https://osv.dev/vulnerability/PYSEC-2026-1701"}],"summary":"NiceGUI apps are vulnerable to XSS which uses `ui.sub_pages` and render arbitrary user-provided links"}